PriceCompass
TP-Link Omada 16-Port Gigabit Smart Switch with 8-Port PoE+

TP-Link Omada 16-Port Gigabit Smart Switch with 8-Port PoE+

TP-Link

TP-Link Omada 16-Port Gigabit Smart Switch with 8-Port PoE+

Model SG2016P

Best price

£168.99atBack to the Office
1 retailer compared

Where to buy

Retailers stocking this product, cheapest first
RetailerPriceAvailabilityVisit
Back to the OfficeCheapestchecked 23 hours ago£168.99In stockVisit Back to the Office (opens in a new tab)

Prices exclude delivery. We may earn a commission if you buy through these links, which never affects the ranking above — it is always cheapest first.

Price history

Full price history

Today's price is above the 51-day average and 14% above the lowest we have recorded, so it may be worth waiting.

£143£168£19327 Aug 202616 Oct 2026
Cheapest price across all tracked retailers. Lowest recorded: £148 on 25 Sept 2026.

Tell me when the price drops

We’ll email you when this gets cheaper. No account needed, and one click stops it.

Optional (£)

We’ll send one email to confirm. Your address is used only for this alert — never for marketing, never shared. See our privacy notice.

About this product

16× Gigabit ports (8× 802.3at/af-compliant PoE+ ports). 120 W total PoE budget with up to 30 W PoE output per port*. Centralized cloud management via the web or the Omada app†. Standalone management via web, CLI, SNMP, and RMON. Static Routing helps route internal traffic for higher efficiency. VLAN, ACL, QoS, and IGMP Snooping. Fanless design for silent operation. Durable metal casing and desktop/wall mounting design. TP-Link’s brand new Omada smart switches provide huge upgrade comparing with previous versions. The switches can be managed by Omada SDN Controller, which provides professional and reliable one-step solutions. Integrated L2 and L2+ features such as 802.1Q VLAN, QoS, IGMP Snooping and static routing provide cost-effective networking solutions for small and medium-sized businesses without sacrificing enhanced usability and strong performance.. Management features. MIB support. RFC1213, RFC1493, RFC2674, RFC2620, RFC2618, RFC2925, RFC1757. System event log. Yes. ARP inspection. Yes. Configuring Location Settings (CLI). Yes. Web-based management. Yes. Cloud-managed. Yes. Quality of Service (QoS) support. Yes. Switch layer. L2/L2+. Switch type. Managed. Ports & interfaces. Power connector. DC-in jack. Basic switching RJ-45 Ethernet ports type. Gigabit Ethernet (10/100/1000). Basic switching RJ-45 Ethernet ports quantity. 16. Network. Number of VLANs. 4000. Virtual LAN features. Multicast VLAN, Tagged VLAN, Voice VLAN. VLAN support. Yes. Link aggregation. Yes. Flow control support. Yes. Auto MDI/MDI-X. Yes. Auto-negotiation. Yes. Rate limiting. Yes. Broadcast storm control. Yes. Ethernet LAN data rates. 10,100,1000 Mbit/s. Spanning tree protocol. Yes. Port mirroring. Yes. Copper ethernet cabling technology. 10BASE-T, 100BASE-TX, 1000BASE-T. 10G support. No. Networking standards. IEEE 802.11w, IEEE 802.1D, IEEE 802.1Q, IEEE 802.1p, IEEE 802.1s, IEEE 802.1x, IEEE 802.3ab, IEEE 802.3ad, IEEE 802.3af, IEEE 802.3at, IEEE 802.3i, IEEE 802.3x. Data transmission. Packet buffer memory. 4.1 MB. Jumbo frames. 9000. Jumbo frames support. Yes. Number of queues. 8. Forwarding rate. 23.81 Mpps. Switching capacity. 32 Gbit/s. MAC address table. 8000 entries. Security. Security algorithms. EAP-MD5, HTTPS, SNMP, SNMPv2, SNMPv3, SSH, SSL/TLS. Authentication. Guest VLAN, MAC-based authentication, Port-based authentication. Queue scheduling algorithms. SP, Weighted Round Robin (WRR). MAC address entries. Dynamic MAC address entries, Static MAC address entries. MAC address filtering. Yes. SSH/SSL support. Yes. BPDU filtering/protection. Yes. IP-MAC-Port binding. Yes. IGMP snooping. Yes. Access Control List (ACL). Yes. DHCP features. DHCP relay, DHCP snooping, DHCPv6 client, DHCPv6 snooping. Multicast features. Multicast Listener Discovery (MLD) snooping. MLD v1, MLD v2. Multicast support. Yes. Protocols. IPv4 & IPv6 features. Dual stack IPv4/IPv6. Supported network protocols. ICMP, TCPv6, UDPv6, Ping6, Tracert6, Telnet (v6), TFTP, TCP/UDP, DSCP/IP, SSLv3, TLS 1.2. GARP VLAN Registration Protocol (GVRP). Yes. Design. LED indicators. PoE, Power, System. Product colour. Black. Rack mounting. Yes. Performance. Fanless. Yes. Firmware upgradeable. Yes. Power. Power consumption (max). 146.5 W. DC input voltage. 53.5 V. Power source. DC/PoE. Power over Ethernet (PoE). Total Power over Ethernet (PoE) budget. 120 W. Power over Ethernet plus (PoE+) ports quantity. 8. Power over Ethernet (PoE). Yes. Operational conditions. Heat dissipation. 499.98 BTU/h. Storage relative humidity (H-H). 5 - 90%. Operating relative humidity (H-H). 10 - 90%. Storage temperature (T-T). -40 - 70 °C. Operating temperature (T-T). 0 - 40 °C. Weight & dimensions. Height. 25.4 mm. Depth. 111.7 mm. Width. 286 mm. Packaging content. Manual. Yes. Cables included. AC. General. Product family. Omada. Certificates. Certification. CE, FCC, RoHS. leaflet. manual pdf. Regulatory Compliance. Installation Guide. Wall Mounting Guide

Similarly priced alternatives we compare across multiple retailers.